Community

Open allianCE for iot stANDard

사물인터넷 디바이스 개발 실습 예제를 돌리다가 질문드립니다.
일엽 안 | 2018-04-11 16:25 | Views 1435


안녕하세요.

문의하신 내용에 대해 답변 드립니다.


지금 하셨던 모든 동작이 정상입니다. ^^;

다만 지금 실행시킨 TAS는  led를 제어하는 TAS 입니다. 그래서 이 led TAS의 경우 외부에서 제어 데이터를 받아서 동작하도록 되어 있기 때문에

TAS에서는 Thyme과 연결을 한 후 외부에서 데이터가 오지 않았기 때문에 아무 동작을 안하는 것처럼 보이지만 현재 listen 상태에 있는 것입니다.


업로드 하신 사진을 보니

/Mobius/light/cnt-led 컨테이너를 만들었고

sub은 /Mobius/light/cnt-led/sub-ctrl2 에 생성했습니다.


그래서 포스트맨 등으로 /Mobius/light/cnt-led에 cin을 생성해 보시면 LED 터미털 창에 데이터가 들어오는 것을 확인할 수 있고 데이터에 따라 LED가 제어되는 것을 보실 수 있을 것입니다.





--------------------------------------------------------------------------------------------------------------------------

안녕하세요. 사물인터넷 디바이스 개발 실습 예제를 돌리다가 질문드립니다.


현재 개발 환경 구축은 다음과 같이 완성하였습니다.


Windows 7 pc : Mobius (MySQL, Mosquitto, Node JS 등) 설치 및 설정 완료


라즈베리파이 : &Cube 및 TAS 설치 완료 했습니다.


여기서 제가 이해가 잘 안되는게..

1. 테스트시 먼저 윈도우의 모비우스 서버를 구동한 후

2. 라즈베리파이에서 /nCube-Thyme 디렉토리의 node thyme.js 를 실행한 뒤

3. /tas 디렉토리의 app.js를 실행하는게 맞는건지요...  


node thyme.js 를 실행하면 

0 - sub-ctrl2 - x-m2m-rsc : 2001 <----

TCP Server (192.168.202.172) for TAS is listening on port 3105

까지 보이고, 

app.js 실행시 thyme.js 쪽에서

socket connected

----> got data for [cnt-led] from tas ----> 와 같은 문구는 뜨지만 

모비우스 서버에서는 아무것도 나오지 않아서요....


원래 thyme.js만 실행해도 자동으로 tas도 실행되는 줄 알았는데 아닌가요...?


사진 첨부합니다.


와이어샤크로 따보니 thyme.js 구동시 모비우스 서버와 http로 패킷이 왔다갔다 하는데 그 이후로는

아무것도 안보이네요... 

File ㅣ thyme & tas.PNG

안녕하세요. 사물인터넷 디바이스 개발 실습 예제를 돌리다가 질문드립니다.


현재 개발 환경 구축은 다음과 같이 완성하였습니다.


Windows 7 pc : Mobius (MySQL, Mosquitto, Node JS 등) 설치 및 설정 완료


라즈베리파이 : &Cube 및 TAS 설치 완료 했습니다.


여기서 제가 이해가 잘 안되는게..

1. 테스트시 먼저 윈도우의 모비우스 서버를 구동한 후

2. 라즈베리파이에서 /nCube-Thyme 디렉토리의 node thyme.js 를 실행한 뒤

3. /tas 디렉토리의 app.js를 실행하는게 맞는건지요...  


node thyme.js 를 실행하면 

0 - sub-ctrl2 - x-m2m-rsc : 2001 <----

TCP Server (192.168.202.172) for TAS is listening on port 3105

까지 보이고, 

app.js 실행시 thyme.js 쪽에서

socket connected

----> got data for [cnt-led] from tas ----> 와 같은 문구는 뜨지만 

모비우스 서버에서는 아무것도 나오지 않아서요....


원래 thyme.js만 실행해도 자동으로 tas도 실행되는 줄 알았는데 아닌가요...?


사진 첨부합니다.


와이어샤크로 따보니 thyme.js 구동시 모비우스 서버와 http로 패킷이 왔다갔다 하는데 그 이후로는

아무것도 안보이네요... 

File ㅣ thyme & tas.PNG