Community

Open allianCE for iot stANDard

LED제어에 관한 질문 올립니다.
Manager | 2017-06-19 18:29 | Views 1272

안녕하세요 OCEAN 담당자 입니다

문의하신 사항에 대해 답변을 드립니다


현재 LED TAS 와 &Cube 간에는 문제가 없어 보입니다

다만 Yellow Turtle 과 &Cube 간에는 어떤 방식으로 통신을 하는지 알수가 없군요

&Cube 의 설정중 conf.useprotocol = 'http'; 로 되어 있는지 확인해 주기 바라며

맞게 되어 있다면

Yellow Trutle 서버가 설치되어 있는 PC의 방화벽을 모두 열었는지 확인 바랍니다

http 방식을 경우

&Cube ---> YT 간에는 http 방식으로 센서데이터가 올라가며

YT ---> &Cube 간에는 mqtt 방식으로 제어 명령이 하달됩니다


부가적으로 conf.useprotocol 의 방식은 현재 3가지가 지원이 되며

- http (주기보고-http, 제어처리-mqtt )

- mqtt (주기보고,제어처리 모두 - mqtt )

- coap (주기보고,제어처리 모두 - coap ) : 이경우 동일 네트웍으로 구성되어 있어야 합니다


확인 바라겠습니다


=======================================================================


안녕하세요. 

라즈베리파이, 모비우스, 샘플 앱을 활용해서 환경구축 해보고있는 학생입니다.

첨부된 사진처럼 포스트맨에서는 SEND를 누르면 좀 이상하지만 응답이 오고있지만

TAS에서는 이상하게 반응이 없습니다. ID는 전부 ae-edu0으로 맞춘 상태입니다.

모비우스 IP도 conf파일들에 잘 적용해둔 상태이고요.


첫번째 사진은 포스트맨으로 send를 날린 사진이고

두번째 사진은 tas를 설치하고 thyme과 led를 연결한 사진이며

세번째 사진은 LED를 직접 켜본 사진인데 세번째 사진처럼 직접 라즈베리파이에서 명령어를 통해 LED를 ON하면 ON이 되기는 합니다만 위에서 말씀드린것처럼 왜 POSTMAN을 통해 TAS로 연동이 안되는지가 궁금합니다. 

답변주시면 감사하겠습니다. 


사진이 한장밖에 첨부되지 않아서 3장의 사진을 압축해서 첨부했습니다.

안녕하세요. 

라즈베리파이, 모비우스, 샘플 앱을 활용해서 환경구축 해보고있는 학생입니다.

첨부된 사진처럼 포스트맨에서는 SEND를 누르면 좀 이상하지만 응답이 오고있지만

TAS에서는 이상하게 반응이 없습니다. ID는 전부 ae-edu0으로 맞춘 상태입니다.

모비우스 IP도 conf파일들에 잘 적용해둔 상태이고요.


첫번째 사진은 포스트맨으로 send를 날린 사진이고

두번째 사진은 tas를 설치하고 thyme과 led를 연결한 사진이며

세번째 사진은 LED를 직접 켜본 사진인데 세번째 사진처럼 직접 라즈베리파이에서 명령어를 통해 LED를 ON하면 ON이 되기는 합니다만 위에서 말씀드린것처럼 왜 POSTMAN을 통해 TAS로 연동이 안되는지가 궁금합니다. 

답변주시면 감사하겠습니다. 


사진이 한장밖에 첨부되지 않아서 3장의 사진을 압축해서 첨부했습니다.

File ㅣ 사진.zip